Классы
Предметы
Важное замечание:

С помощью наших видеоуроков вы сможете:
1. Подготовиться к завтрашнему уроку в школе.
2. Научиться грамотно пользоваться компьютером на домашнем уровне.
3. Понять основные тенденции и логическую основу этой отрасли.

Но если вы хотите стать специалистом, обратитесь к таким сайтам, как Codecademy.com, Teamtreehouse.com, www.piktomir.ru.

Поскольку информатика (и всё, что с ней связано, — электроника, робототехника и т.д.) — быстроразвивающаяся отрасль, школьная программа по ряду тем может отставать от действительности.

Если вы специалист и хотите добавить актуальную информацию, снять дополнение к уроку, пишите нам на info@univertv.ru.

Программирование в ЛОГО. Создание циклических программ. Вложенные циклы. Многоугольники

К изучению предлагается тема «Программирование в ЛОГО. Создание циклических программ. Вложенные циклы. Многоугольники». Мы продолжаем осваивать программирование в ЛОГО. На этом уроке разберем создание циклических программ, использование вложенных циклов. Научимся составлять программы для рисования правильных многоугольников.

Информатика 6 класс

Глава 1.Программирование в Лого.

Урок 3. Программирование в Лого. Создание циклических программ. Вложенные циклы. Многоугольники.

 

Вложенные циклы, задача на использования вложенных циклов (4 квадрата)

На этом уроке мы научимся использовать созданные ранее циклические программы для рисования более сложных фигур. Для этого достаточно поместить в тело одного цикла второй цикл.

Иллюстрация решения задачи о построении 4 квадратов в среде Лого

Рассмотрим такую задачу:

Напишите программу рисования данной фигуры (рис 1).

Рисунок 1. Большой квадрат, который состоит из 4 маленьких.

 

Вложенный цикл описывает алгоритм рисования квадрата. В соответствии с внешним циклом черепашка 4 раза рисует квадрат, поворачиваясь после рисования каждого на 900. В результате вы увидите на экране большой квадрат, составленный из четырех маленьких.

Команда для выполнения выглядит следующим образом:

повтори 4 [повтори 4 [вп 40 пр 90] лв 90]

Решение нашей задачи выглядит следующим образом:

1.                      На листе программ (рис. 2) мы видим нашу программу для рисования. Название операции – пример.

Рисунок 2. Программа для рисования квадрата.

2.                      На листе выполнения (рис. 3) вы видите кнопку для выполнения программы и результат ее работы. Также на листе можно увидеть кнопку сг (сотри графику), с такой кнопкой редактировать изображение намного легче.

 

Рисунок 3. Результат работы программы для рисования квадрата.

 

Создание узоров с помощью вложенных циклов

Создание узоров с помощью вложенных циклов

Рассмотрим теперь, как создавать различные узоры при помощи вложенных циклов.

Задание:

Разработайте программу рисования узора вида (рис. 4):

Рисунок 4. Узор.

Для решения задачи внимательно посмотрим на рисунок и обнаружим, что узор тоже состоит из квадратов. Количество квадратов увеличилось до 8, то есть в 2 раза.

Команда для выполнения будет иметь вид:

повтори 8 [повтори 4 [вп 40 пр 90] лв 45]

Рисование правильных многоугольников

Рисование правильных многоугольников

Как в математике, так и в информатике есть понятие правильный многоугольник. Научим черепашку рисовать любые правильные многоугольники.

Многоугольник называется правильным, если все его стороны и углы равны.

Для того чтобы написать соответствующую процедуру, следует заметить, что угол поворота черепашки для правильной фигуры можно получить по формуле:

Угол = 360 / количество сторон

В качестве примера можно рассмотреть правильный шестиугольник.

Рассчитаем угол поворота черепахи для правильного шестиугольника: .

Его можно нарисовать такой командой:

повтори 6 [вп 50 пр 60]

Иллюстрация рисования правильных 3-угольника, 5-угольника, 6-угольника, 8-угольника в среде Лого

Рассмотрим теперь построение других правильных многоугольников, а именно 3-угольника, 5-угольника, 6-угольника 8-угольника. Программы для построения этих фигур (рис. 5) и результаты их работы (рис. 6) вы можете увидеть на рисунках:

Рисунок 5. Программы для рисования некоторых многоугольников.

Рисунок 6. Многоугольники, нарисованные в Лого

То есть, мы пишем программу:

· 3-угольник : по повтори 3 [вп 60 пр 360 / 3];

· 5-угольник: по повтори 5 [вп 60 пр 360 / 5];

· 6-угольник: по повтори 6 [вп 60 пр 360 / 6];

· 8-угольник: по повтори 8 [вп 60 пр 360 / 8].

        

Рассмотрим теперь программы для построения более сложных фигур.

Задание:

Составить программу построения домика с условием, что черепашка не должна проходить дважды по одной и той же линии. Начальное положение выберите самостоятельно. Стороны квадрата и треугольника равны.

Домик состоит из крыши и основания (двух правильных многоугольников). Основание представляет собой квадрат, крыша – равносторонний треугольник. Низ крыши и верх основания – один и тот же отрезок.

Составим примерный алгоритм рисования домика:

1.                      Нарисовать квадрат, начиная с нижней вершины, и вернуться в ту же точку.

2.                      Нарисовать крышу – стороны треугольника.

Нарисовав квадрат, черепашка должна перейти в верхнюю левую вершину. Перо должно быть поднято.

При рисовании треугольника нужно перо опустить и повернуть голову черепашки влево на угол 300 для того, чтобы основание треугольника располагалось параллельно верхней стороне квадрата. Полученная программа для рисования домика:

это домик

по повтори 4 [вп 60 пр 90]

пп вп 60 пр 30

по повтори 3 [вп 60 пр 120]

конец

Результат ее работы приведен ниже (рис. 7):

Рисунок 7. Домик

Теперь попробуем написать еще более сложные программы. Создадим программу рисования трех домиков, расположенных на одной горизонтали и имеющих одинаковый размер.

Программа для рисования:

это домики

повтори 3 [повтори 4[по вп 60 пр 90]

пп нк 45 вп 15 нц 45 крась

нд 15 нк 0 вп 60 по нк 45

вп 43 нк 135 вп 43 нк 285

пп вп 5 нц 65 крась нд 15

нк 180 вп 60 нк 90 вп 40 нк 0 ]

конец

Сначала мы рисуем все 3 домика, а потом последовательно их закрашиваем. Вспомним, чтобы закрасить область, необходимо с поднятым пером разместить черепашку внутри замкнутой фигуры, выбрать номер цвета и применить команду крась.

Результат такой программы (рис. 8):

Рисунок 8. Три домика

 

Список рекомендованной литературы.

1)   Босова Л.Л. Информатика и ИКТ: Учебник для 6 класса. – М.: БИНОМ. Лаборатория знаний, 2012

2)   Босова Л.Л. Информатика: Рабочая тетрадь для 6 класса. – М.: БИНОМ. Лаборатория знаний, 2010.

3)   Босова Л.Л., Босова А.Ю. Уроки информатики в 5-6 классах: Методическое пособие. – М.: БИНОМ. Лаборатория знаний, 2010.

 

 

Рекомендованные ссылки на ресурсы интернет.

1)   http://markx.narod.ru/logo/

2)   http://logomir.com/

3)   http://logoworlds.chat.ru/

 

Рекомендованное домашнее задание.

1)    Напишите программу рисования следующих изображений, используя циклы:

Рисунок 9.

Рисунок 10.